Author Topic: Problem playing 1080p files  (Read 10048 times)

Offline Servaan

  • Member
  • Posts: 15
Problem playing 1080p files
« on: September 09, 2011, 01:47:18 am »
So I got a problem playing 1080p files (1920x1080 reso) if you can help would be appreciated, will try to inform about my computer and whatnot as much as possible.
My computer is Acer Aspire M3200, im using MPC-HC with the latest CCCP and CoreAVC (not sure if theyre 100% perfectly set up).
To the problem. For example, Mushishi (not sure where I got this but its really good quality) and Code Geass (OCZ-release from this site) work fine, both are 1080p.
Theres a bit of this laggy effect when the "background is scrolling" but its pretty minimal and I am ok with it for the most part.
However, today I downloaded Black Lagoon (OCZ from this site again) and the intro is lagging like hell. The same lag with the moving background, again not really that bad.
HEEEERE is the real problem though. Bakemonogatari, not the 10-bit release (tried it, with latest cccp, its lagging like hell and its impossible to watch) but the 1080p normal encoding, because it was freeleech I took it instead of the 720p which is enough for me anyways (same with black lagoon, freeleech too tempting lol), and even the normal 1080p lags. Alot. Not all the time, but at some points of the first episode it just went totally out of sync and started pausing and whatnot...

So yeah, the point of this thread was to get some help with setting up something that would help me watch that stuff better. Help greatly appreciated, thanks.

EDIT: actually I think I didnt have coreavc on properly, watched a video how to set it up to mpc. Changed it. Difference? None.
« Last Edit: September 09, 2011, 02:05:52 am by Servaan »

Offline Gnabgib

  • Member
  • Posts: 201
Re: Problem playing 1080p files
« Reply #1 on: September 09, 2011, 02:19:19 am »
There are a lot of different versions of the Acer Aspire M3200.  Can you be more specific as to what the specs of the PC are?  Most importantly the CPU information is needed.

If you can tell what filters are in use in MPC-HC that would be helpful.  Right click with the video loaded and list everything under filters.

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #2 on: September 09, 2011, 03:06:43 am »
There are a lot of different versions of the Acer Aspire M3200.  Can you be more specific as to what the specs of the PC are?  Most importantly the CPU information is needed.

If you can tell what filters are in use in MPC-HC that would be helpful.  Right click with the video loaded and list everything under filters.

System : Acer Aspire M3200, AMD Athlon Dual Core Processor 4050e (2 CPUS), ~2.1GHz, 3070MB RAM, DirectX 11, Windows Vista Home Premium. Not very good with this specs stuff but looked this up on dxdiag hope it helps.

Filters : Default Directsound Device, Video Renderer, Audio Switcher, DirectVobSub (auto-loading version), ffdshow audio decoder, CoreAVC video decoder and then the path for the file, it seems its possible to change the audio track from there too.

I messed around on the internet looking, found this pretty good guide http://www.logichaos.com/joomla/guides/35-text-guides/91-how-to-configure-media-player-classic-and-coreavc.html but it didnt help at all in the end. Tried everything in there, didnt seem to help (and other sites too, im not stupid). I think it propably has something to do with ffdshow... Gotta go to sleep now, its 4:00 am in the night here, hopefully when I wake up tomorrow I wont have to mess around too much with this stuff, its driving me crazy. Heeeelp!

Offline Ozzaharwood

  • Member
  • Posts: 2371
  • ζ༼⊙ ͟ل͜ ⊙༽ᶘζ༼⊙ ͟ل͜ ⊙༽ᶘζ༼⊙ ͟ل͜ ⊙༽ᶘ
Re: Problem playing 1080p files
« Reply #3 on: September 09, 2011, 03:12:36 am »
Could you try this and tell me what happens? :

Play a video that usually lags, but this time have task manager opened. (You can do this by pressing ctrl+alt+delete, and selecting task manager) Go to the performance tab and have that opened while the video is playing. As soon as it starts lagging check to see if your CPU or RAM is at or near 100% of it's limit.
This happens a lot and seems to be a common case with MPC when maxing out video quality. It happened to me as well, and I almost have identical specs to yours. If this is the case, all you have to do is close all processes and applications that you aren't using to keep down your CPU/RAM.

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #4 on: September 09, 2011, 03:19:20 am »
In DirectVobSub / VSFilter options, under misc, first try raise buffer to 10. If that doesn't work, untick animation.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline OZC

  • Member
  • Posts: 54
Re: Problem playing 1080p files
« Reply #5 on: September 09, 2011, 04:56:14 am »
In DirectVobSub / VSFilter options, under misc, first try raise buffer to 10. If that doesn't work, untick animation.

This will probably fix the intro issues on Black Lagoon, since the blurred edges + fades on the lyrics are kind of a strain on processing. I usually avoid that sort of thing but the effect looked too good.

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #6 on: September 09, 2011, 01:27:40 pm »
Hey, back again. @Ozzaharwood, tried it, and that seems to be most of the problem. Turned off every unused program and my CPU is going insane with the bakemonogatari episode. At 80-100% most of the time. In black lagoon the number was alot lower. @namaiki that helped actually. It even fixed most of the lag on bakemonogatari, theres this weird experimental part at about 75% of the episode and it went completely batshit with the sound and video and subtitles before, this fixed it for the most part. Still its lagging at one point but it fixed 2 parts almost completely. So I guess its the CPU thing now. The RAM was basically unaffected, so its not from that. Do I need to upgrade my computer? Or is there still some trick that might help? Thanks for the help so far.

EDIT: Checked the intro on black lagoon and its fixed, only at some points does it lag, and when it lags the CPU is at 100%.
« Last Edit: September 09, 2011, 01:31:50 pm by Servaan »

Offline Stsin

  • Member
  • Posts: 1948
Re: Problem playing 1080p files
« Reply #7 on: September 09, 2011, 03:40:38 pm »
If you are really intent on playing 1080p with that system, can try using DXVA.

With CCCP installation in MPC-HC:
Go to View > Options > Internal Filters.  Under the transform filters, enable "H264/AVC (DXVA)".  Double click it and enable "Disable DXVA for SD".

Should be enough to get it working on some files.  A more in depth tutorial: http://imouto.my/watching-h264-videos-using-dxva/

You'll get better quality without using DXVA, so may want to disable it after viewing problematic 1080p.




Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #8 on: September 09, 2011, 03:48:10 pm »
If your computer has the Radeon 3200, I would not recommend DXVA but it doesn't hurt to try as the reset option in the CCCP Settings application will generally fix things up.

Some more stuff -- switch video renderer in MPC-HC.
If you don't often take screenshots, try use EVR. If you do take screenshots, then update the directx runtimes ( http://www.microsoft.com/download/en/details.aspx?id=35 ) in your computer.



Download and install the latest LAV filters. ( http://forum.doom9.org/showthread.php?t=156191 )

Make sure to close all media related applications first.

After that, do a reset + re-register in the CCCP Settings application on the second page.

Open the CCCP Settings application and then untick H.264/AVC.

When you open a video, LAV video should appear in the Filters menu in MPC-HC (instead of CoreAVC, or ffdshow video decoder).
« Last Edit: September 10, 2011, 11:04:31 pm by namaiki »
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Stsin

  • Member
  • Posts: 1948
Re: Problem playing 1080p files
« Reply #9 on: September 10, 2011, 10:26:24 am »
My onboard GPU is similar to the 3200.  Though I only had it enabled when testing Win7 Beta, it did DXVA quite well, including 1080p.  That is for the files that are compliant with 4.1 back then.  But with the latest Catalyst drivers should do higher.  That's another thought, make sure you have the latest Catalyst drivers too.
« Last Edit: September 10, 2011, 10:27:55 am by Stsin »

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #10 on: September 10, 2011, 10:38:00 pm »
Thanks for the help. I wont go into really doing that crazy LAV thing though, i'm not watching 10-bit as  of now anyways. And the only show that really lags bad is bakemonogatari, and I can pass up on one show, I mean Code Geass, Mushishi, and Black Lagoon all work fine. I'm not even sure the scenerey lags when it moves or i'm just imagining it. I updated my drivers though and I think it helped a bit.

Offline jokli

  • Member
  • Posts: 104
Re: Problem playing 1080p files
« Reply #11 on: September 11, 2011, 12:30:40 am »
Thank you very much for suggesting the LAV filters, they are already doing a good job here!  :-*

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #12 on: September 11, 2011, 08:20:14 pm »
Now theres a weird problem, using this cause I don't wanna make a new thread just for this. Downloaded BL roberta's bloodtrail ([tastymelon] from nyaatorrents 720p) and the scenery lag is alot worse than in anything before. Thats when I use fullscreen. If I don't, its not lagging AT ALL. So I just though if theres a solution to this... What could be causing it to only do this in fullscreen? Guess I'm just a perfectionist and can't help it...

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #13 on: September 12, 2011, 03:19:26 am »
Now theres a weird problem, using this cause I don't wanna make a new thread just for this. Downloaded BL roberta's bloodtrail ([tastymelon] from nyaatorrents 720p) and the scenery lag is alot worse than in anything before. Thats when I use fullscreen. If I don't, its not lagging AT ALL. So I just though if theres a solution to this... What could be causing it to only do this in fullscreen? Guess I'm just a perfectionist and can't help it...
Please tell me what items are listed in the menu: Play-> Filters.
Also, please tell me what resizer is set in View-> Options-> Output, if Aero is enabled or disabled, what graphics card is in your computer, and how many monitors are hooked up to your computer.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #14 on: September 12, 2011, 01:39:13 pm »
Please tell me what items are listed in the menu: Play-> Filters.
Also, please tell me what resizer is set in View-> Options-> Output, if Aero is enabled or disabled, what graphics card is in your computer, and how many monitors are hooked up to your computer.
[/quote]

Graphics card : ATI Radeon HD 3600 series.

Monitor : One monitor, it came bundled with the computer. Combined cost was about 700€ (I live in finland) I dunno if that helps at all. It was cheap as fuck though, considering that the time this was a good computer. It is Acer too but no idea about anything else.

Filters : Default Directsound Device, Video Renderer, Audio Switcher, DirectVobSub (auto-loading version), ffdshow audio decoder, CoreAVC video decoder and then the path for the file, it seems its possible to change the audio track from there too. (already said this in a earlier post)

Resizer : Blinear, VRM9 mixer mode ticked. I have Directshow video on system default, could this have anything to do with anything? Like interfering with the CoreAVC?

EDIT : "Go to View > Options > Internal Filters.  Under the transform filters, enable "H264/AVC (DXVA)".  Double click it and enable "Disable DXVA for SD"

I dont even have an option to do that, there is no such thing. Damn this thread is getting long, but I guess these sorts of things arent solved that easily.
« Last Edit: September 12, 2011, 01:43:42 pm by Servaan »

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #15 on: September 12, 2011, 01:42:40 pm »
Hmm, do you ever take screenshots? If no, try change video renderer to EVR.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #16 on: September 12, 2011, 01:47:27 pm »
Hmm, do you ever take screenshots? If no, try change video renderer to EVR.

I don't have that option either. Do I have an old version of MPC-HC? Shouldnt be, I use the one bundled in CCCP latest release.

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #17 on: September 12, 2011, 01:49:32 pm »
Try reinstall the latest CCCP and use the MPC-HC from:
Start-> Programs-> Combined Communiy Codec Pack-> Media Player Classic Homecinema.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #18 on: September 12, 2011, 02:09:41 pm »
Try reinstall the latest CCCP and use the MPC-HC from:
Start-> Programs-> Combined Communiy Codec Pack-> Media Player Classic Homecinema.

Finally fixed. Thanks everyone. No lag. THERE IS NO LAG! Even the archdemon 1080p Bakemonogatari bows down before me. YES YES!!! Oh man... Feels good.

Solution was to reinstall cccp and I had to reroute my "automatically play this file with". I had it on Media Player Classic, but it was the older version I used ages ago for some reason. When I rerouted it, I finally had the option to go EVR. And guess what? With just that change, BAM every lag in every video I have is gone. Miraculous. Thank you so much man...

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #19 on: October 04, 2012, 02:01:51 pm »
Bump with new problem, I don't think this will be as hard to fix though. On [a-s] 1080p AAC bdrip release of Full Metal Panic!, the subtitles are weird. The subtitles first of all are too much to the right. I am not sure if this is how they are supposed to be, but I don't think it makes any sense and I've never seen this done before, the lines first letter is almost at the center part of the screen at the bottom. The bigger problem is that they keep disappearing, especially at around episode 9 and 10 for a few lines here and there, which is annoying even though I for the most part understand what they're talking about. Is this a problem with the file itself? I don't know what it could be. I tried messing around with the subtitle buffer but to no effect. It might be that because the subtitles are too far to the right and when a longer sentence comes it is cut off completely?

A smaller problem : For example at 16:10 of episode 6 (FMP!), where there is this "flaky" effect the audio skips and the video lags. Black Lagoon's opening also uses this one and it lags too, even without subtitles on that caused the problem before. It's not a big deal since I've only seen this used in maybe 3 shows and it doesn't last very long but if there is an easy fix it would be nice.

At the moment I'm using MPC-HC + CCCP with all internal filters checked off, on external I got LAV Video, LAV Audio and Directvobsub (auto-loading) cause of xy-vsfilter which I have set up properly. EVR Custom pres on Output. Could this be a problem with xy-vsfilter? I also tried playing back with VLC (2.03) which also had the subtitles failing, so maybe it isn't. Maybe it's the files themselves?

I feel kinda lame always bugging you with this stuff but I guess that's what the playback forum is for. Specs and stuff should be found in the 3rd post of this thread.

EDIT: Forgot something. madVR is not an option, it lags like no tomorrow on my old beat up computer, tried it many times.
« Last Edit: October 04, 2012, 02:06:03 pm by Servaan »