Author Topic: Problem playing 1080p files  (Read 10181 times)

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #20 on: October 04, 2012, 02:09:02 pm »
Could you post a screenshot of the issue? Also, maybe try delete c:\Windows\System32\FNTCACHE.DAT and then restart.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #21 on: October 05, 2012, 01:11:28 am »
Could you post a screenshot of the issue? Also, maybe try delete c:\Windows\System32\FNTCACHE.DAT and then restart.
Here's a screencap of the "subtitles to the right" problem. http://imageshack.us/a/img546/5577/fmpplaybackproblem.jpg
There is no "FNTCACHE.DAT" file, only a VCD and DLL with the same name. Is it the VCD one? Google'd a bit about the dll one and it says it's not a good idea to remove it atleast. I don't want to remove stuff from sys32 without knowing first so I'll wait for confirmation. No point in taking a scrnshot of the "disappearing subs", it's just the lines not appearing.

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #22 on: October 05, 2012, 01:18:27 am »
Are those PGS subs? If so, that's a known issue.

Quote
Q: Why aren't Blu-ray PGS subtitles showing on my cropped/resized video?
A: Blu-ray PGS subtitles often have a fixed resolution of 1920x1080. Unless the encoded video frame matches the PGS subtitle resolution, no subtitles will be displayed. This is a limitation of the VSFilter 2.40 PGS code we are using. You can workaround this problem by padding the video back to 1920x1080. FFDShow users can use it's Resize filter to pad the video. LAV Video users can set temporarily set xy-VSFilter Vertical Padding to Extend to 16:9 (requires xy-VSFilter to be restarted).

Basically, the side of the video has been cropped off, but the subs don't know that.

Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #23 on: October 05, 2012, 01:48:16 am »
Are those PGS subs? If so, that's a known issue.

Quote
Q: Why aren't Blu-ray PGS subtitles showing on my cropped/resized video?
A: Blu-ray PGS subtitles often have a fixed resolution of 1920x1080. Unless the encoded video frame matches the PGS subtitle resolution, no subtitles will be displayed. This is a limitation of the VSFilter 2.40 PGS code we are using. You can workaround this problem by padding the video back to 1920x1080. FFDShow users can use it's Resize filter to pad the video. LAV Video users can set temporarily set xy-VSFilter Vertical Padding to Extend to 16:9 (requires xy-VSFilter to be restarted).

Basically, the side of the video has been cropped off, but the subs don't know that.

Nope, didn't fix it, if I understood correctly. Went to filters->directvobsub properties->general-> Vertical padding and I set it to 16:9 and then closed and opened MPC. Both the text remains too far to the right and the lines still disappear. Did I do something wrong?

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #24 on: October 05, 2012, 02:17:51 am »
Try set ffdshow video to resize the video to 1920x1080. The padding thing should work (did you reload the video?) though I haven't tried it myself.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #25 on: October 05, 2012, 03:55:54 am »
Try set ffdshow video to resize the video to 1920x1080. The padding thing should work (did you reload the video?) though I haven't tried it myself.
I might be failing something here but nope, no luck. What I did : FFDShow Video Decoder Configuration-> Resize & Aspect -> [X] Resize, 1920x1080. It didn't seem to do anything except the player itself moved down a bit, dunno why and what happened. When that didn't work, I went to external filters and disabled LAV Video Decoder and added ffdshow video decoder if that was the problem but apparently not, and somehow the filters still show LAV as the decoder? So I go and remove it from the list completely (restarting player between all these steps ofc) and nope, still says LAV as decoder in filters when accessed from right click-> filters on the video.

Did I miss or fail something? And yes the vertical padding didn't do jack either. I'm too tired to try any further, I'll check back after sleeping and try some things it might be (changing the aspect ratio to 16:9 in the ffdshow settings is one possibility), also messing around with why it still shows LAV although it's disabled. The problem most likely is, like you said, that the subtitles are too far to the right to be seen, but none of the fixes seem to help. Oh yeah, and what about on the main window of directvobsub, there is this "override placement" thing, is it possible to use that the reposition the subtitles? I tried messing with it a few days ago but I don't know how to use it properly so nothing happened.

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #26 on: October 05, 2012, 01:59:02 pm »
Is ffdshow video decoder listed at all in the Play-> Filters menu?
« Last Edit: October 05, 2012, 02:01:33 pm by namaiki »
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #27 on: October 05, 2012, 03:22:03 pm »
Is ffdshow video decoder listed at all in the Play-> Filters menu?
Now I understand, it was set to LAV Video from the CCCP settings. I changed them into ffdshow h.264 playback from there and now the subtitles are fixed and in the center properly, but like I predicted, the ffdshow can't handle the video without lagging like hell, so that option is out the window.

And now I also get why the vertical padding didn't work : I had set it to extend 16:9 instead of crop 16:9 (but why in hell does it say extend to 16:9 in the guide then lol). But here is where it gets strange, when I went back to the LAV + directvob and properly cropped it, now the video is correctly filling the entire screen (and it looks good so far), but of course it isn't that simple, now the subtitles won't show at all. Then I tried again messing with the override placement thing but it doesn't seem to make the subtitles show up. I think the solution is near though, can I somehow manually place them in the middle or something?

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #28 on: October 05, 2012, 03:37:40 pm »
You can put "ffdshow raw video" something in between of LAV Video decoder and directvobsub.

Add it to the External Filters list in MPC-HC and you can set it to resize there. Can't remember if you are supposed to put it on top of or below DirectVobSub in the External Filters list (it matters!).
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline Servaan

  • Member
  • Posts: 15
Re: Problem playing 1080p files
« Reply #29 on: October 05, 2012, 05:36:52 pm »
You can put "ffdshow raw video" something in between of LAV Video decoder and directvobsub.

Add it to the External Filters list in MPC-HC and you can set it to resize there. Can't remember if you are supposed to put it on top of or below DirectVobSub in the External Filters list (it matters!).
Okay, now it works. Directvob needs to be below it, otherwise it won't work. Does the ffdshow raw video interfere with other types of video play or should I only use it for this one? Oh well I guess it doesn't matter, I can always manually do this since it isn't hard when I know what to do now so thanks for the help, again. Props to you man. Didn't have time to fully check it out but seems to have fixed atleast the centering problem atleast a sample part I tried where the texts used to disappear.

Offline zherok

  • Member
  • Posts: 2525
Re: Problem playing 1080p files
« Reply #30 on: October 06, 2012, 01:33:45 am »
EDIT: Forgot something. madVR is not an option, it lags like no tomorrow on my old beat up computer, tried it many times.
madVR is usually recommended because it's the best looking option. There are definitely less performance intensive renderers.

Online kitamesume

  • Member
  • Posts: 9302
  • Death is pleasure, Living is torment.
Re: Problem playing 1080p files
« Reply #31 on: October 06, 2012, 07:53:49 am »
it is possible to make madvr lighter, theres a few options to adjust them.

they're under "scaling algorithms" and "rendering", adjust the parameters there and it should be much more lighter.
but madvr will still end up being heavier than the lightest renderers.

Offline cyberbeing

  • Member
  • Posts: 62
Re: Problem playing 1080p files
« Reply #32 on: October 12, 2012, 01:19:19 am »
The subtitles first of all are too much to the right. I am not sure if this is how they are supposed to be, but I don't think it makes any sense and I've never seen this done before, the lines first letter is almost at the center part of the screen at the bottom.

Considering this is a 16:9 (4:3 picture w/ pillarboxing) Blu-ray, with a 4:3 cropped re-encode, the problem is that [a-s] muxed the full-frame 1920x1080 PGS as-is. VSFilter only contains a method for vertical padding, which won't help you at all since you need horizontal padding.

How to fix 1920x1080 PGS on 1440x1080 video:

Option A) Demux the PGS subtitles, use BDSup2Sub Convert Resolution to 1440x1080 & Free Scale Y=0.75, export/save them as SUP(BD), and mux them back into the MKV replacing the existing PGS subtitles.

Option B) Use FFDShow's resize filter to re-add the black pillarboxes on each side, "Specify Aspect Ratio = 16:9" & "Keep Original Aspect Ratio"

Option C) Use MPC-HC's internal subtitle renderer for watching shows with cropped video and PGS subtitles

Option D) OCR the PGS to ASS softsubs (hint: [a-s] has two different FMP BD releases, one with PGS and the other with ASS subs)

Note: For all of these options, leave xy-VSFilter vertical padding set to the default setting of "Original height".

And now I also get why the vertical padding didn't work : I had set it to extend 16:9 instead of crop 16:9 (but why in hell does it say extend to 16:9 in the guide then lol).
Setting Vertical Padding to 'Extend to 16:9' is only correct for vertically cropped 16:9 video with PGS subtitles. Vertical Padding shouldn't be used at all for horizontally cropped video. Setting 'Crop to 16:9' will just crop off the top and bottom of your 1440x1080 4:3 frame to a 1440x812 16:9 frame, which probably isn't what you want. If you have a 16:9 monitor, watching a 4:3 video like this one isn't supposed to fill the entire screen. Having black pillarboxes on the left and right sides is normal.

The bigger problem is that they keep disappearing, especially at around episode 9 and 10 for a few lines here and there, which is annoying even though I for the most part understand what they're talking about. Is this a problem with the file itself? I don't know what it could be. I tried messing around with the subtitle buffer but to no effect. It might be that because the subtitles are too far to the right and when a longer sentence comes it is cut off completely?

If the issue is 1920x1080 PGS on 1440x1080, you are correct that subtitles which exceed the 1440 width of the video frame which VSFilter renders to, wouldn't be displayed.

If instead this is an issue with multiple overlapping PGS lines not being displayed, this was a known issue in VSFilter's PGS parser for years, which just recently got fixed by MPC-HC a month or so ago. The fix for multiple overlapping PGS has already been merged into xy-VSFilter, and will be included in the next stable release.
« Last Edit: November 18, 2012, 06:45:17 am by cyberbeing »

Offline onlyforKG

  • Member
  • Posts: 13
Re: Problem playing 1080p files
« Reply #33 on: October 27, 2012, 11:23:21 am »
Imma noob here and experiencing same problem. Whenever I try to play 1080p videos, they lag so bad I can't watch it (eg. Metantei Holmes and Detective Conan Magician of the Silver Sky). I am using HP Mini 210-1100, Intel Atom processor (1.86GHz, 2 CPUs), DirectX 11, win7 premium. I tried MPC-HC and it quite improve the playback of the videos I'm trying to watch but the audio is a bit low and laggy.
mada mada dane

Offline xgraphy

  • Former Staff
  • Member
  • Posts: 1381
Re: Problem playing 1080p files
« Reply #34 on: October 27, 2012, 11:35:43 am »
Intel Atom processor (1.86GHz, 2 CPUs)
I believe this is your problem, don't think you can 'fix' this.

Offline onlyforKG

  • Member
  • Posts: 13
Re: Problem playing 1080p files
« Reply #35 on: October 27, 2012, 01:26:08 pm »
Intel Atom processor (1.86GHz, 2 CPUs)
I believe this is your problem, don't think you can 'fix' this.

can't there be any other players which can support it? :(
mada mada dane

Offline namaiki

  • Member
  • Posts: 1155
Re: Problem playing 1080p files
« Reply #36 on: October 27, 2012, 01:30:27 pm »
Intel Atom processor (1.86GHz, 2 CPUs)
I believe this is your problem, don't think you can 'fix' this.

can't there be any other players which can support it? :(

It's too slow. If you want, you could try install CoreAVC and disable deblocking and also install and use xy-vsfilter. Also, I'd try to stick with 720p and lower.
Kaoru + Aoi + Shiho = Infinity
For video playback: madVR + CCCP 2011-11-11 (use the bundled version of MPC-HC)
https://www.youtube.com/watch?v=jXBQ

Offline kureshii

  • Former Staff
  • Member
  • Posts: 4509
  • May typeset edited light novels if asked nicely.
Re: Problem playing 1080p files
« Reply #37 on: October 27, 2012, 01:47:06 pm »
Intel Atom processor (1.86GHz, 2 CPUs)
I believe this is your problem, don't think you can 'fix' this.

can't there be any other players which can support it? :(

Can't a 60cc engine move an 18-wheeler?

Offline vuzedome

  • Member
  • Posts: 6930
  • Reppuzan~!
  • Awards Winner of the BakaBT Mahjong tournament 2010
    • GoGreenToday
Re: Problem playing 1080p files
« Reply #38 on: October 27, 2012, 02:05:57 pm »
To be honest, my old Intel pentium Dual-Core 1.8GHz can run it, but I doubt an Atom even has the wattage to move.
BBT Ika Musume Fan Club Member #000044   
Misaka Mikoto Fan Club Member #000044
BBT Duke Nukem Fan Club Member #0000002

Offline onlyforKG

  • Member
  • Posts: 13
Re: Problem playing 1080p files
« Reply #39 on: October 27, 2012, 03:13:36 pm »
It's too slow. If you want, you could try install CoreAVC and disable deblocking and also install and use xy-vsfilter. Also, I'd try to stick with 720p and lower.

thanks! Now I understand. I might have to borrow another laptop. lol. Thanks for the help :D
mada mada dane