Author Topic: Strange green line in MPC-HC when watching .mp4  (Read 419 times)

Offline Krudda

  • Member
  • Posts: 10323
  • 私は 日本語 が 上手 じゃ ありません
    • My Anime List
Strange green line in MPC-HC when watching .mp4
« on: July 26, 2016, 11:21:54 am »
I've had this issue for a while now but it only happens with .mp4 container videos.

I cannot work out why, but that line always appears at the top of every video with a .mp4 extension.


Sorry but you are not allowed to view spoiler contents.
I'm using MadVR codec and I think I installed XY-VS filter



Does anybody know what could cause this line? It only appears when using MadVR codec.

Offline sneaker2

  • Member
  • Posts: 240
Re: Strange green line in MPC-HC when watching .mp4
« Reply #1 on: July 26, 2016, 04:30:54 pm »
I don't know what causes this but if your MPC-HC is already >2 years old I'd simply update everything first. MPC-HC (nightly), XySubFilter and madvr. (in the newest MPC-HC you select XySubFilter in the same menu you select madvr)

If it still persists look into Play->Filters to see if LAV + XySubFilter + madVR are actually the only components being used (you can copy-past the list here). If it only happens with MP4 there's a chance it uses some different filters for that (Microsoft?). Make sure LAV is used for mp4s as well.

Offline Bozobub

  • Member
  • Posts: 1744
  • Demon Lord of Clowns
Re: Strange green line in MPC-HC when watching .mp4
« Reply #2 on: July 26, 2016, 07:18:55 pm »
I'd uninstall all codecs and reinstall the newest version of the K-Lite, CCCP, or Kawaii codec pack, your choice.  I've had similar artifacts due to outdated and/or buggy codecs.

If that doesn't do it, try toggling your MPC-HC to use the internal Source and Transform filters, or vice versa, depending on what they're using now.

Offline Krudda

  • Member
  • Posts: 10323
  • 私は 日本語 が 上手 じゃ ありません
    • My Anime List
Re: Strange green line in MPC-HC when watching .mp4
« Reply #3 on: July 27, 2016, 10:43:16 am »
I don't know what causes this but if your MPC-HC is already >2 years old I'd simply update everything first. MPC-HC (nightly), XySubFilter and madvr. (in the newest MPC-HC you select XySubFilter in the same menu you select madvr)

If it still persists look into Play->Filters to see if LAV + XySubFilter + madVR are actually the only components being used (you can copy-past the list here). If it only happens with MP4 there's a chance it uses some different filters for that (Microsoft?). Make sure LAV is used for mp4s as well.
Its a fresh install as of about 2 weeks ago. I just used an old installer for MPC-HC. My laptop was actually running a newer version than what I am using right now.
Everything else is up to date.

I'll try updating MPC-HC and see if that helps.

E: Updating did not help. reinstalling all codecs did not help, installing windows updates did not help.

Only thing I can think of is to update Windows 7 to SP1

Either that, or put up with people looking like they're half asleep.
« Last Edit: August 13, 2016, 11:49:22 pm by Krudda »

Offline AnimeOokami

  • Member
  • Posts: 46
  • The big "bad" wolf.
Re: Strange green line in MPC-HC when watching .mp4
« Reply #4 on: August 25, 2016, 05:38:20 pm »
According to both of your screenshots you are using hardware decoding, have you tried disabling it?

Offline Krudda

  • Member
  • Posts: 10323
  • 私は 日本語 が 上手 じゃ ありません
    • My Anime List
Re: Strange green line in MPC-HC when watching .mp4
« Reply #5 on: August 25, 2016, 09:32:22 pm »
According to both of your screenshots you are using hardware decoding, have you tried disabling it?
Hadn't thought of that.
I'll give it a try.

After updating to SP1, the problem mostly went away, but some files still persist with the error, and actually became more pronounced. Its almost as if the luma or chroma channel is being displayed below the rest of the video by a few cm.
I'll give new screenshots once I've had time to disable H/W decoding.